読者です 読者をやめる 読者になる 読者になる

echo("備忘録");

IT技術やプログラミング関連など、技術系の事を備忘録的にまとめています。

Ruby on Railsのインストールでnokogiriがエラーになる

前々から興味を持っていたRuby on RailsをGW中に勉強しようと思い、下記の本を参考にRubyRuby on Railsのインストールを実施。

 

www.amazon.co.jp

RubyDevKit、Node.jsインストールは問題なし。

SQLiteは…MySQLがあるから、とりあえずは後回し。

で、Ruby on Railsをインストールしようとしたら、以下のエラーが発生。

ERROR:  Error installing rails:
        nokogiri requires Ruby version < 2.3, >= 1.9.2.

 

 あれ?バージョン2.3未満じゃないと駄目なの?(私がインストールしたのはバージョン2.4)

 

…と思っていたら、同じ現象が発生した方がいたようで、解決方法が記載されていました。

world02.hatenablog.com

 

 参考までに、解決方法を共有させて頂くと、

1.以下のコマンドを実施。

gem install nokogiri -v '1.6.6.4'
gem install rails 
gem install nokogiri -v '1.6.8.rc3'

 

 2.gemfileに以下を追記

gem 'nokogiri', '>=1.6.8.rc3'

 

 でOKです。

 

インストール直後は色々問題が発生するとはいえ、まだまだ勉強したてなので、

こういう情報は本当にありがたいです。

 

…でも、一日でも早く、自分がこういう情報を提供する側になれるよう、頑張らないといけませんね。